
e-mail 

Telefoon 020-6 352 350
Verkoop 020-6 352 351   
Administratie 020-6 352 352   
Techniek 020-6 352 353
Offertes 020-6 352 357

info@nelec.comwholesaler Nelec BV

www.nelec.com
Gyroscoopweg 106
1042 AX  Amsterdam
Postbus 20674
1001 NR  Amsterdam

intercom made easy
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1. Hardware and Software requirements

2. Installation

To install the TiSwitchboardDevice software proceed as follows:
1.  Insert the CD-ROM in the CD drive;
2.  Launch the TiSwitchboardDevice application and follow the installation procedure.
3.  The installation program will start copying the system files needed to run the TiSwitchboardDevice software. 
4.	 If not already present, the MICROSOFT.NET FRAMEWORK 3.5 SP1 must also be installed. To install it launch the 

dotnetfx35SP1 that can be found in the CD-ROM supplied.

Minimum requirements

.NET framework 3.5 SP1

Processore Pentium 2 GHz or similar

RAM 1GB

Display 800 x 600, 256 colours

CD or DVD Drive

Hard disk 500 MB minimum free space

Supported operating systems Service pack 32 bit 64 bit

Windows XP SP2 Yes No

Windows Vista - Yes Yes

Windows 7 - Yes Yes
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TiSwitchboardDevice

3. Fundamental concepts 

The TiSwitchboardDevice can be used for the creation and configuration of a project for the management of a switchboard.
The configuration created can be saved in a file and downloaded to the switchboard. In the same way, the configuration 
already in the switchboard may be uploaded to the software, to be checked and/or changed.

3.1 Function menus and pushbuttons

All the functions that can be performed with TiSwitchboardDevice can be selected by clicking the icons on the toolbar, or 
by selecting the appropriate items from the pull-down menus.
The toolbar includes the following functions:

Creating, Opening and Saving the configuration file

Configuration Upload and Download 

Device firmware update   

Request device info

Application language selection

Connection to the www.biticino.com website

3.1.1 “File” menu” 

•   New
	 To create a new project
•   Open
	 To open an existing configuration file
•   Save
	 To save the current project
•   Save as 
	 To save the current project prompting the user to enter a name
•	 Exit
	 To exit the program



6

3.1.2 “Tools” menu

• 	 Upload
	 To upload the configuration from the device
• 	 Download
	 To download the configuration to the device
•	 Update firmware 
	 To update the device firmware
•	 Request device info
	 To display some technical information

3.1.3 “Language” menu

• 	 Language
	 To select the application language

3.1.4  “?” menu

• 	 About... 
	 To display some TiSwitchboardDevice program information
• 	 Supported version
	 To display the list of firmware versions supported by the TiSwitchboardDevice program 



TiSwitchboardDevice

So
ft

w
ar

e 
M

an
ua

l

7

4. Project

This section describes how a project should be managed.

4.1 Project creation

In order to create a project start the TiSwitchboardDevice program; this will display an opening screen followed by the 
localisation screen, where the user can select the language and the corresponding package.

If required, add a new localisation package by selecting the appropriate pushbutton Add Localization package. 
Click Confirm to display the main screen, from where the project configuration procedure can be started. 



8

The left area shows a tree menu listing all the configuration parameters in hierarchical order. 
When an item on the tree menu is selected, the right side of the window shows the corresponding data input area, where 
the configuration details can be entered. 

The project has now been created. A new project can also be created by selecting New from the File menu.

Toolbar Pull-down Data Data input area

Tree menu Function description areaProject configuration 
error/warning area
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4.2 Project configuration 

This section is used to enter the switchboard identification details, and the parameters for the interaction of the 
switchboard with the configured system.

4.2.1 TiSwitchboardDevice
• 	 Project name
	 - Select TiSwitchboardDevice from the tree menu.
	 - Enter the name to be assigned to the project in the right window.

4.2.2 Connections
• 	 Device address
	 - Select SCS from the tree menu.
	 - Enter the specific switchboard system address.
	 - Define the switchboard operating mode: Main or Secondary. 
	   If secondary, enter the address of the main switchboard.

•  	Main EU (External Unit)
	 - Select Main EU from the tree menu.
	 - Enter the address of the external unit. 
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4.2.3 Security
In this section it is possible to set an installer password for the configuration of the device. 

• 	 Password
	 - Select Authentication from the tree menu.

- 	Enter the installer switchboard configuration password.  
	 The password must consist of 5 digits between 0 and 99999

4.2.4 Settings 
This section can be used to configure the setup functions for the switchboard operating mode. 

•  	Function keys
	 This is used to set the functions to associate to the 12 keys, and the corresponding address if necessary.
	 - Select Function keys from the tree menu.
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	 - Click the “Key function settings” field and the corresponding key on the right.
	

 - 	Select the function to associate to each key from the pull-down menu and, in the case of  “IU - EU – Switchboard” calls, the 
SCS address.  Click    to save the settings, or     to cancel the action.
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•  Keypad tones
	 This is used to enable/disable the keypad tones
	 - Select Keypad tones from the tree menu.

	 - Click the enable/disable field and select the desired setting from the pull-down menu.
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•  Locks
	 This is used to enable/disable up to 5 door locks, with address and riser setup. It also gives the possibility of entering 

individual descriptions for each lock. 
	 - Select Lock from the tree menu.

	 - Click the lock enable field and select the setting from the pull-down menu.

	 - Click on the relevant fields to enter a lock description, the lock address and the lock riser.
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•  Alarms
	 This section can be used to enable/disable the reception of alarms detected by the Alarm Modules and then sent to the 

switchboard.
	 - Select Alarms from the tree menu.

-	 Click the relevant field and enable/disable the corresponding operation.  In addition to enable/disable, the settings 
also include the “Day only enable” option. 
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•  Camera
	 - Select Camera from the tree menu.

	 - Click the enable field and select the desired setting from the pull-down menu. 
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4.2.5 Call Settings 
This section can be used to configure some call setting functions.

•  	Call type
	 - Select Call type from the tree menu.
	 - Select the desired Call type:
	    By Apartment
	    By Block - Floor - Extension

•  	Night/Day
	 - Select Night/Day from the tree menu.
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	 External Units
	 - Click the Mode field and the corresponding arrow to toggle between Manual and Automatic.

- 	 Click Enabling mode and the corresponding arrow to select the External Units for which the operating mode 
will be set.

	 - Click the External Unit List field and the corresponding pushbutton on the side to create a list of the “EU” set.
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	 - The following window appears.
	 It is now possible to add, remove, or amend the list of External Units “EU”. 
	 Click    to add a new EU.
	 Click    to delete the selected EU.
	 Click    to delete all EU.

Click the address field to change the value using the pull-down menu.

Save the new External Unit “EU” list by clicking the  pushbutton. 
Click the  pushbutton to close the window without saving the changes made.
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	 Time bands
	 - Click the Time bands field and the corresponding pushbutton on the right

- The following input window appears.
- Enter the times in order to define the operation of the switchboard in day or time mode; up to 6 time bands can be 

set, based on needs
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	 Indoor Units
	 - Click the IU Status field and the corresponding IU status enable/disable arrow. 

-	 If enabled, click the IU Operation Mode field and the corresponding arrow to toggle between Manual and Automatic.

- When in Automatic, operation will follow the set Time Bands.
- When in Manual mode, the switchboard can decide when to switch from one status to the other. 
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•  	Service IU
	 - Select Service IU from the tree menu.

	 - Click the Service IU field and enable or disable its operation.

- 	 If enable, enter the address of the service internal unit address that will answer the call if the switchboard operator is absent.
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4.2.6 Ringtones
Once all settings have been completed, click   to go to the ringtone section.  
If the project has not yet been saved, the “Save as” window appears, where the user can enter the desired project name 
and the path.

The ringtone setting window appears.

The left section shows the list of ringtones available. 
The   icon can be used to load a new ringtone. 
The   can be used to delete the ringtone highlighted.
The  icons are used to play or pause the selected ringtone.
On the right section use to    key to add and configure an event, associating it to a ringtone selected among the ones 
present.
The    key removes the selected event.
The  icons are used to play or pause the ringtone of the selected event. 
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Once the events have been entered, they must be configured selecting the parameters from the pull-down menus.

Click on the headings to sort the events based on the allocated sequence number.  
Click    to return to the previous page. 
Click   to return to the initial configuration. 

4.2.7 Address books
Once the ringtones have been configured, click  to go to the third page, Address Book Configuration. 
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To add new contacts:
-  Set the element type by selecting either Entrance panel, Apartment, or Switchboard from the pull-down menu.
-  Enter the number of desired elements.
-  Click Add to add the elements in the window on the right.

-  Click Delete All to delete all the contacts entered. 
-  Click Delete selection to delete the selected contact. 
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Once the contacts have been entered, it will be possible to change the name and the corresponding address by clicking 
on the corresponding fields.

If the Block – Floor – Extension  mode is selected for the call type, also these items will be displayed and can be changed. 
Click on the headings to sort the various elements in increasing/decreasing order.

On the bottom section of the left window it is possible to select a contact type among entrance panels - apartments – 
switchboards, or to deselect all contacts.
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Select the Filter tab to switch to the filter section, and only display elements meeting certain conditions.

Enter the Type or the Name in the corresponding field. 
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Click Filter Numbers to only display the contacts with the set features.

Click Reset filters to display all elements again.

4.2.8 Exit the project
Once the project has been completed, it must be saved using the  icon, or by selecting File – Save, and checking that 
the project name is correct.  
If Exit is selected without saving the project first, the user will be prompted to save the file.
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4.3 Saving a project

This function can be used to save an active project (.prj).
- Select Save from the File pull-down menu.
- or select the  icon on the toolbar. 

A window will appear for the selection of the folder the project should be saved to.

Enter the project name and click Save to save the project.
If a project with the same name already exists, an overwrite confirmation request window appears.

Note: if the project was already saved during the configuration, when Save is selected the file will be overwritten with 
the latest changes.
Using the Save as command, the user can specify a new name to save the current project.
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4.4 Opening a project

Once the configuration file has been saved, this control enables selecting it to make changes, or for downloading it to the 
switchboard.
- Select Open from the File pull-down menu.
- or select the    icon on the toolbar.

A window appears, where the user can search for the folder containing the project file (.prj) to open.

Select Open to open the project.
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5. Downloading a project to the switchboard 

This function can be used to download the configuration created using TiSwitchboardDevice to the switchboard. 

To download the configuration to the switchboard:

-  From the Tools pull-down menu select Download.

-  or select the   icon on the toolbar.

The following window appears.
Select the Date and Time to set on the device and click Next to continue.

Select the connection mode and click Next.
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Select the port the switchboard is connected to and click Next.

The window for the transfer of the data to the switchboard appears, listing all the operations being performed.

A detailed or a summarised view of the operations performed is also possible, as well as exporting to a log file for 
saving on the PC.   
In case of error, press Retry all failed operations to repeat all the data transfer operations.
Once the procedure has been completed click OK.
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6. Uploading a project from the switchboard 

This function can be used to load the configuration from the switchboard to TiSwitchboardDevice, to carry out switchboard 
checks and/or amendments.

To upload the configuration to TiSwitchboardDevice:

-  select Upload from the Tools pull-down menu.

-  or select the  icon on the toolbar.- 	

The following window appears:
Select the connection mode and click Next.
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Select the port the switchboard is connected to and click Next.

The window for the transfer of the data to the switchboard appears, listing all the operations being performed.

A detailed or a summarised view of the operations performed is also possible, as well as exporting to a log file for 
saving on the PC. 
In case of error, press Retry all failed operations to repeat all the data transfer operations.
Once the procedure has been completed click OK.
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7. Firmware Update

This function can be used to update the permanent base software (firmware) using the revisions published by 
BTicino.

To activate the procedure:

-  From the Tools pull-down menu select Update firmware.

-  or select the  icon on the toolbar.

A window appears, where the user can search for the folder containing the Firmware file:

Click Find and select the file; Click Next to continue.
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8. Request device info

This function can be used to display some device technical firmware and hardware information. 
To activate the procedure:

-  From the Tools pull-down menu select Request device info. 

-  or select the   icon on the toolbar. 

The following window appears:
Select the connection mode and click Next.
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Select the port the switchboard is connected to and click Next.

The window for the transfer of the data to the switchboard appears, listing all the operations being performed.

A detailed or a summarised view of the operations performed is also possible, as well as exporting to a log file for 
saving on the PC. 
In case of error, press Retry all failed operations to repeat all the data transfer operations.
Once the procedure has been completed click OK.
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BTicino SpA
Via Messina, 38
20154 Milano - Italy
www.bticino.com

BTicino SpA reserves at any time the right to modify the contents of this booklet and to communicate, in any form and modality, the changes brought to the same.


